Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Popular Discussions

    Skype for iPhone: Tip to Fix Crashing Issue on Jailbroken iPhone; Make VOiP Calls over Data Network

    ^_^^_^ Posts: 4,429
    via Wordpress in iPhoneHacks.com
    imageSkype for iPhone: Tip to Fix Crashing Issue on Jailbroken iPhone; Make VOiP Calls over Data Network [Updated]

    Skype released their much-awaited VOiP iPhone App late last night on the App Store. Unfortunately, users who have jailbroken their iPhone and installed jailbreak apps have observed that Skype's iPhone app is very unstable and crashing very frequently. If you're one of them then there is a solution to fix...

    Read the full story here

    «1

    Comments

    • PhilippePhilippe Posts: 6
      via Wordpress

      Nothing on Appstore Canada

    • DeanDean Posts: 125
      via Wordpress

      I had skype on my iPhone when I want
      To sign up it start crashing,but when I
      Update all my apps at cydia skype now
      Working.

    • PhilippePhilippe Posts: 6
      via Wordpress

      Is there a way to download the file and install it without getting it from the app store?

    • iPhoneHacksiPhoneHacks Posts: 2,315
      via Wordpress

      Unfortunately, as per CBC News:

      Skype's public relations representative said this is because of patent-licence restrictions but would not elaborate except to specify that it is a patent issue related to Skype, not Apple.

      We have also updated the post with this info.

    • JJ Posts: 131
      via Wordpress

      man...i was totally stoked thinking icould use this over 3g..but only wifi? boooo....

    • mbhullarmbhullar Posts: 43
      via Wordpress

      With the latest version of mobile substrate and turning “on” App Launch Boost in Intelliscreen and selecting VoIPover3G I am able to make calls over 3g with no crashes. When I turn off the App Lauch boot I get the standard message that calls cannot be made due to carrier restrictions.

      I DID not add “com.skype.skype” to the list.on /Library/MobileSubstrate/DynamicLibraries

      Lots of other folks on thebigboss.org thread have confirmed the above mentioned setting works....

    • iPhoneHacksiPhoneHacks Posts: 2,315
      via Wordpress

      That worked. Excellent!!!

      Thanks for tip.

    • JohnyJohny Posts: 10
      via Wordpress

      Hi guys

      it seems that this trick with Mobile Substrate update is not working for me. Its still crashing. I also removed Clippy app.

      any clue?

    • mbhullarmbhullar Posts: 43
      via Wordpress

      Johny, the upgrade to the latest version of Mobile Substrate has worked practically for everyone. I would recommend going through the install again, I recall there were two updates that came out today (thebigboss.org)make sure you are on the latest.

      Hope that helps out.

      Mandeep

    • JJJJ Posts: 48
      via Wordpress

      johny

      make sure you have not turned backgrounder on for skype and do a reboot. the trick for intelliscreen works as well but it seems like you have to buy the app in 10 days. hopefully a solution will be found without it before then.

    • TomTom Posts: 314
      via Wordpress

      Isn't working for me either and I OWN Intelliscreen. I have a 1st Gen iPhone, has anyone had success with that? It always crashes when I tap on the username and password fields. The signup runthrough works ok.

    • SSSSSS Posts: 7
      via Wordpress

      I tried all ways, but it crashed all ways.

      jailbroken IP 2.2
      1, install skype, type to sign in, crashed
      2, uninstall skype, upgrade mobile substrate to 0.9.2804-1, install skype, sign in, crashed
      3, run in safe mode in sbsetting, sign in, crashed
      4, enable intelliscreen, sign in, crashed

      what should I do?

    • Caco PotosoCaco Potoso Posts: 14
      via Wordpress

      Not working for me either. What a pain!

    • JohnyJohny Posts: 10
      via Wordpress

      i guess the crashing during the signing in is connected with clippy and background application. You have to disable them.

      My problem is that even after that and updating on newest Mobil Substrate Skype crashes after 40 sec.

      I have no idea what could be

    • ABANABAN Posts: 1
      via Wordpress

      Update to 2.2.1 which I believe us the latest version

    • JohnyJohny Posts: 10
      via Wordpress

      and just now I received another update for Mobile Substrate but still same problem. I upgraded to 0.9.2805-1, deleted clippy and backgrounder but my Skype is still crashing after 40 sec.

    • TimWTimW Posts: 430
      via Wordpress

      for those with Clippy & SBsettings, disable clippy via the toggle AFTER LATEST M/SUBSTRATE & CLIPPY UPDATES
      Reinstall / Install Skype
      REBOOT (not respring)
      Try skype test call
      Toggle Clippy on with SBs.
      Retry Skype
      Should work after these steps

      If you uninstall MobSub. REBOOT before installing skype to remove residual files

      This has worked on mine & 3 other iPhones
      Hope it helps


    • TimWTimW Posts: 430
      via Wordpress

      Update!!!
      Install of Cracked X apps causes Skype failure
      Why? I don't know
      I removed ALL cracked apps from mates phone and skype worked

    • via Wordpress

      Mobile Substrate just released another updates, it now fully supports Skype!

    • Steve jobsSteve jobs Posts: 57
      via Wordpress

      Make sure you have latest version of MobileSubstrate from Cydia (>= 0.9.2805)!
      This version does not crash Skype and allows VoIpOver3G and Backgrounder to be run together with Skype, which makes Skype (and the iPhone) really useful!!!!
      :-)

      Thank you saurik (developer of cydia and mobilesubstrate (among other stuff))!!!!!!

    • JohnyJohny Posts: 10
      via Wordpress

      i did all that but still crashing...

    • Vishal ShethVishal Sheth Posts: 2
      via Wordpress

      This is not working.

    • mbhullarmbhullar Posts: 43
      via Wordpress

      There's yet another mobile substrate update that doesn't require the inteliscreen hack and works fine with 3g/edge and backgrounder. I just followed that thread on thebigboss.org, check if that resolves your issue.

      Mandeep

    • HayesHayes Posts: 1
      via Wordpress

      I think there is a 2805-1 update.

    • mminoomminoo Posts: 2
      via Wordpress

      Known extensions or apps that cause skype to crash: mcoolphone, mobilelog, iLog, AdvLock, Hood

      You have uninstall this programs, so skype would work on the latest Mobilesubstrate update over wifi or 3G.

      Good luck all,

    • OlliverOlliver Posts: 22
      via Wordpress

      Hi mbhullar, all works fine here, I figured I dont really need Intelliscreen to make Skype calls over data-network, all works with Voipover3G in the end (adding "com.skype.skype").

      But out of curiosity, where is the "App Launch Boost" in Intelliscreen, I just cant find it?

      Thanks

    • mbhullarmbhullar Posts: 43
      via Wordpress

      Olliver,
      I am on a slightly older version of Intelliscreen V2.32 and this has the Performance row towards the end where you can turn Off/On App Launch Boost, based on what I've read on a different site the latest version of Intelliscreen does not have this feature anymore. This is the reason you are not seeing it.

      Mandeep

    • OlliverOlliver Posts: 22
      via Wordpress

      I would like to add Intelliscreen to the list of intefeering apps (with Skype).
      Got the initial crash problem yesterday, solved it with updates of Mobile Substrate 1 and 2. The second one got Voipov3G to work with Skype and all was fine, could make calls over mobile-operator.
      Installed Intelliscreen 1h ago and it started to crash again after 20sec, uninstalled and its now all back to good again.
      Now I cant uninstall the RockYourPhone base app unless doing a restore as I understand it, anyway not a big issue but if anyone out there knows how to do that it would be appreciated.
      Saludos from Spain

    • TomTom Posts: 314
      via Wordpress

      Clippy toggle/reboot, etc didn't help me either. No cracked apps. Probably something to do with Intelliscreen. Why is Skype so wiggy?! Not worth it.

    • YegaYega Posts: 1
      via Wordpress

      Just to confirm this works. Like Steve said, you need the latest MobileSubstrate and then add the following to your VoIPover3G.plist:

      "com.skype.skype"

      so it reads something like:

      ...MobileStore", "com.skype.skype");};

      I "tested" over 3G and GPRS and Skype launches fine. Don't know what the call quality is like tho..

      Saurik, you rule!!

    Sign In or Register to comment.