Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Popular Discussions

    uh oh...

    jyjljyjl Posts: 2
    edited August 2012 in Jailbreak Forum
    I'm a total newb. I just jailbroke (is that a verb?) my 3GS. Now, email doesn't work (black screen), Safari doesn't work (opens for a second then just closes) and this Cydia thing that I was so anxious to try also doesn't do anything (like Safari, just opens for a sec then closes). Did I do something wrong? Can anyone help me fix this, please? I'm using an iMac, if that makes a difference. Thanks.


    • RounakRounak Posts: 269
      That sounds like something that would happen after a tethered jailbreak, but the 3GS jb is completely untethered. I'm assuming you already tried resarting your phone and that didn't work.
      The last resort would be to restore the firmware on the phone and re-jailbreak it
    • jyjljyjl Posts: 2
      Thanks for your comments. Yes, it was untethered, using redsn0w for mac 0.9.14b2. I restarted a few times and also tried restoring from backup: fail. I restored the firmware (iPhone 3GS 5.1.1/9B206): success. Thanks Rounak. Unfortunately, now I'm reluctant to try jailbreaking again...
    Sign In or Register to comment.