Help please! I recently re-jailbroke my iPod Touch 4g on 6.1.6 with Redsn0w 0.9.15b3 It wont turn on

Okay, so...I recently re-jailbroke my iPod because I kinda missed being able to do really cool things with it like downloading apps that were originally on the app store for like 6 dollars and up, for free and putting cool lock screens on it...stuff like that. Well I saw on this video that, with my firmware, I could jailbreak it with Redsn0w 0.9.15b3. (I should probably mention by now that my home button is broken...) Well I couldn't enter it into DFU mode like normally so the video stated that the newest version of Redsn0w allowed it to where you could make a regular ".ispw" file into a "Enter DFU" .ispw file to kick it into DFU mode with iTunes without having to use my home button to jailbreak it, so I did just that and at first it didn't work, I fooled around with it a little by just repeating the steps over again like 3 times and finally it worked. It booted up as a new iPod and asked me if I wanted to restore with my backup. I decided I wanted to do that instead and when it booted back up everything was fine, I had my original background and it was trying to download my apps and such and I finally had Cydia. I laid it down to go eat dinner, I came back to the iPod to get on Cydia and fix my iPod up but when I came back the screen was black. I thought it was just locked to where I'd have to put in my password again but when I went to do that it didn't respond. So I figured it died or tried to restart and reboot, but couldn't or something. So I went back to Redsn0w to do "Just boot" again after selecting my .ispw and it didn't work. My iPod wouldn't turn back on. I went to iTunes and it was syncing, acting like as if my iPod was on or something but my screen was still black. I went to press the power button and it showed up a white screen and then I pressed the power button again and it went black again. Well then I tried restoring it on iTunes to just bring it back but it gave me an error code 1600. I went into my "Hosts" file and deleted everything after (for example) and then saved it and tried it again and then it gave me error code 1601. About this time I was upset and tried messing with redsn0w again to see if that would bring it back and now it wont do anything. When I plug it in, my computer doesn't show it. iTunes acts like I haven't plugged anything in and Redsn0w doesn't say my iPod at the bottom of it either so it's like I haven't plugged it in at all. I don't know where to turn anymore. No one will help me. If anyone has actually tried to read all of this and is crazy enough to help me bring this iPod back, you are truly amazing. xD I'm thinking about buying a new or used iPod to jailbreak but they're pretty expensive. Anything will help! This thing was a 32gb iPod and I have a bunch of music so...yeah. xD Please help!!! Again, keep in mind, I have a broken home button...and if I try to fix the button I wont know if it actually works, because my iPod doesn't work...This is just a last resort idea to see if it can be done before I buy a new one.