iPhone 4S stuck at the boot loop after simple turn off

Hello iPhonehackers!

I've hit a very specific issue with my older iPhone 4S running iOS 7.1.2.
I was doing some App Store updates during the last weekend and as my 32GB space was almost full (300MB free) the app update process failed. After canceling the app update process I realized there is barely no free space left (5 MB free).

I probably made a mistake when I didn't immediately clean up some space by deleting apps or some other content. Instead I just switched the iPhone off and tried to restart it to let the iOS do some cleanup of temporary space and update caches etc. But from that moment it got stuck in the boot loop when it shows only the white Apple logo over and over again.

I already tried to do some resetting following the procedure with Home and Power/Sleep buttons that I found on the internet but it really didn’t help. I was also able to switch the iPhone to Recovery mode with plugging it to my MacBook Pro via USB and holding Home button. However I didn’t yet try to do iOS Restore yet it as I don't have full backup of all the data. I do have some partial iCloud backup of data but unfortunately but it does not include all the photos from the Camera Roll which would take quite a lot of the iCloud space that I had to use for other backups of my iOS devices. But now I’m really banging my head that I didn’t make at least manual backups of ALL data via iTunes so that I could easily restore via Recovery mode.

I thought that iOS 7 really got the problem to boot because of very low empty space after those App Store updates.
So my question is if there is ANY way how I could make my iPhone 4S boot to iOS so that I can make a backup?
Is it possible to do some reset of iOS without loosing any data?
Or is it at least possible to boot it into some special mode so that I could access the data?
I've read about some DFU mode which is used to update the iOS without wiping any data.
As I understood DFU mode can be used to bypass the normal boot and is used also for jailbreaking.
So could it somehow help me to resolve this using some tool?
Or what else I should try without sacrificing the data?

Please help me! I would be really grateful for any advices and suggestions..
Thank you very much!