Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Popular Discussions

    Hack to Enable MMS on iPhone OS 3.0

    124

    Comments

    • heffreyheffrey Posts: 3
      via Wordpress

      Thanx Steven M, Ive wrestled with many ways, this one is working so far!

    • via Wordpress

      This doesnt work,i set it up followed all the steps and sent 2 messages. Then ATT set my phone back to an IPHONE from a Razor and now i cant send MMS. If i swap the SIM back and wait for the ATT site to update it might work but then after a bit of usage ATT will change my phone back to the IPHONE.

      I dont know how everyone else is getting this to work, but its not working on my phone an ive follow all the instructions i could find and have worked with a few IPCC files...all to end up with no MMS.

    • William OrdonezWilliam Ordonez Posts: 1
      via Wordpress

      Steven, I did exactly what you instructed to do and it work perfectly. I went onto the website (mymedianet.wireless.att) and I switched phones. It worked all day yesterday, (the day I did it) and i tried it today again and it stopped working. Did I do anything wrong. Was I supposed to do something when I was in the website that I had to do to make sure it did not revert to the iphone settings? Thank you for all your help, we really appreciate it.

    • Energyzer BunnyEnergyzer Bunny Posts: 2
      via Wordpress

      Ok.... this is what you do.. and what i did... Google iphone at&t 5.0 for iphone download... download it and unzip it.. once its unziped go download Itunes 8.2 BETA it must be beta IT MUST!!! then install it and Shift click on "Check For Updates" then go to the unzipped at&t 5.0.ipcc file and click on it once thats dun u should be getting atleast the sign next to the texts to send mms ok.. then reset your iphone and go to Options>General>Network>Cellular Data Network and then go down to "MMS" and make it
      APN: wap.cingular
      Username: [email protected]
      Password: CINGULAR1
      MMSC: mmsc.cingular.com
      MMS Proxy: 66.209.11.32
      MMS Max Message Soze:
      MMS UA Prof URL:

      ok then Hold power button and slide to shutdown... then turn back on and take out simcard... put simcard into a old phone or into a friends/family members... Send exactly 1 MMS text out and 2 calls... then go to http://mymedianet.wireless.att.com./ put your number in and do what it says then take out your iphone simcard and put it in your iphone Walla u can now send texts


      If you need help send me a email [email protected]
      Have fun and have a garrreat nighttt

    • Energyzer BunnyEnergyzer Bunny Posts: 2
      via Wordpress

      Ugh ok now i just checked im getting what [email protected]'s getting ok im not gonna mess with my iphone.... ok lets wait till this comes out cuz i heard sum people have screwed there iphones up... at&t's fault

    • sonicfloodsonicflood Posts: 1
      via Wordpress

      Well, I can send pics but I can't receive them. Very strange!

    • zxylaphonezxylaphone Posts: 1
      via Wordpress

      i tried this and even tested mms in a non iphone after following the instructions and it threw a "user barred" warning and didnt send the mms.

    • DavidDavid Posts: 225
      via Wordpress

      I had to go into info for the ipcc because it kept trying to change it to zip (even though it says .ipcc) Just change the extension to ATT_US.ipcc and click 'Use .ipcc'

    • Ahiska4everAhiska4ever Posts: 1
      via Wordpress

      Hell yeah its working on 2g thanks !!!!!!!!!!!!!!!! i tried everything and it wasn't working but after i replaced the sim card and make the call after i can !!!!!!!!!!!!!!!!!!!!!!

    • LukeLuke Posts: 51
      via Wordpress

      Well, I got it to work after updating the IPCC and swaping the sim to an older phone. I'm on a family text messaging plan. After 2 successful MMS messages sent out, it began to say message failed. This was all within a 15 minute period. I can't wait until the day that the iPhone comes out unlocked or for verizon/tmobile and AT&T cries in the corner as millions of its users flock to other networks. They need to learn how to treat customers if they want to keep customers.

    • LukeLuke Posts: 51
      via Wordpress

      Ok, I figured it out. If you install swirlyMMS2 after you do all of the things listed above, MMS will work! When swirly runs, it tricks AT&T that you are using a different phone, so you won't run into the problem about AT&T recognizing that you changed back from an old non-iphone to your iphone. YAY! I'll keep you updated on whether or not it keeps working.

    • SME1011SME1011 Posts: 1
      via Wordpress

      This worked great! a few things though..
      there is a slightly easier way to do this without getting another phone and messing around with all that. after you add the ipcc to your phone, you can go to http://help.benm.at/help.php and click on the mms icon, select your country and carrier, and input the info into Settings > General > Network > Cellular Data Network > MMS
      Hope this helps!

    • MarcoMarco Posts: 34
      via Wordpress

      I got it to enable the feature BUT when sending the MMS it just doesn't send PLUS it screwed up the ICCID.

    • dennisdennis Posts: 89
      via Wordpress

      UPDATED!!!!!

      Well if im not mistaken, everyone on here should be having the same issue. It stopped working for me as well. It's not the phone, really, it's AT&T. Once I got mms to work with the 5.0 ipcc, AT&T's network blocked it again. I just learned that AT&T has a block on all iPhone that was under their subsidy deal with Apple. So unless you have an original iPhone 2g that has been jailbroken/unlocked, that was never registered with AT&T, and you're still using AT&T's network, than you don't have the block on the phone. Unfortunately we all have to wait till AT&T removes the block on all iPhones they have registered and enlisted in thier system for each individual phone in order to enable mms. This would mean that you have to have a data plan with them and your account has to be registered with an iPhone. This sucks and yes I know this is a lot of bull. The only other way way to bypass AT&T's network block is to fake the imei on the iPhone. By doing this Att cannot know what phone youre are using and will not block the phone from sending and recieving mms on their networks. Not only is that illegal but the only jailbreak that allowed such a thing was ziphone which only supports firmware 2.2.1 and below. The problem is ziphone doesn't play nice with cydia, installer, or icy. I'm sorry to break the news for you.

      I've gotten mines to work but AT&T's system is so sophisticated it knows when your sim card is in the iPhone. I kept having to switch it out in order to get it to work. At one point I had to leave my sim card in the other phone for a week before I put it back into the iPhone so that I can get mms to work and not even an hour later mms was blocked again. I'm sorry.

      I guess we'll all have to wait and see till august for att. If this becomes a big issue even after, im hoping the devteam can allow a config to spoof the imei to trick the network. I'll keep you all posted.

      email me with any questions [email protected]

    • dennisdennis Posts: 89
      via Wordpress

      Oh and ps. If you guess really want to piss ATT off. here what you should do.

      I have an iphone jailbroken unlocked using a standard rate plan with a $30 data on top and everything works including tethering. the only thing not working is mms. It took me 4 hours but i managed to get a $65.00 credit for haveing feature that would not work on a phone that is capable of doing those features. So everybody knows that apple now supports mms on both the 3g and 3gs. If you call att and let them know that the phone now supports it and you have mms on your service they HAVE TO GIVE YOU A CREDIT. They will of course try to tell you that the phone does not support mms, but you can ask them to get an apple rep on the line with you and the apple rep will tell them the phone does support mms. Now remember if youre like me and started out with an iphone data plan and decided to call att back up let them know that youve broke or lost your phone(which they cant do anything about because they do not offer insurance for the device), and let them know that you have a spare (or even a cheap pay as you go phone) and tell them you would like to remove the data plan and of course they will. They'll ask you for the imei of the spare phone to put in the account. Now all you have to do is log into your att account and add the most inexpensive data plan if you want data back on. Now when youre on the phone with customer care, they'll try to say that you dont have an iphone on the account because the imei is showing for a different phone. They try and say anything to avoid giving you the credit. They'll even say that if you put your sim card back into the spare phone mms will work. To counter this tell them that if you take it out it will work on the iphone as well then after about an hour it will stop. Thats proof that ATT has strict control over what you do with your service over what phone you have on the account. And if they are still relucntant try this.....ready..........tell them..........

      "what if i brought my iphone outside the United States unlocked and i took my sim card out and placed in my phone, now shouldn't i be able to use what ever features I am paying for. Because I am actually just paying for service which i am not getting."

      once again they'll try to tell you that the phone does not support it but you have the apple rep telling them it does and they will be force to give you some kind of credit on the account. Att knows that a lot of travelers have unlocked phones that they bring to the usa that uses quad band frequencies. They allow their network to be used for Alien phones such as the nokia n5. This is how it should be. Now for a service to have control over a device that is manufactued by someone else is just far out greedy and selfish. You let them know that T-mobile allows customers to have service with unlocked iphones on their networks for data plans as low as 19.95 that includes mms that works on a phone that ATT claims does not support the feature. You let them know that and I guarrantee if you escalate it to a supervisor they'll give you a credit. It took me four hours to get something. I believe in you. YOU CAN DO IT. LETS MAKE THIS COMPANY REINBURST US FOR GOING THROUGH THIS FUSTRATION!!!!! WHOS WITH ME????

      PLEASE LET ME KNOW HOW THIS TURNS OUT.
      [email protected]

    • dennisdennis Posts: 89
      via Wordpress

      take advantage while you can
      this just in........

      Torqued over the lack of tethering support from AT&T? Taken matters into your own hands? TUAW has learned that, with the release of iPhone OS 3.1 beta 2, tethering via the IPCC hack no longer works for AT&T customers.

      While iPhone OS 3.0 provides support for tethering, AT&T has yet to officially support it. As a workaround to obtain tethering (as well as MMS for some), some users have modified their carrier files (IPCC). As of 3.1 beta 2, this no longer works.
      It's not that surprising that Apple would want close this loophole... but it is a little surprising that AT&T has yet to announce a firm date or rate plan for US customers to tether their iPhones.

      [It should go without saying, but if you enable tethering on your 3.0 iPhone, you do so at your own risk; AT&T may slam you with a data overage bill or worse.]

    • iPhoneNinjaiPhoneNinja Posts: 14
      via Wordpress

      To the iPhoners who cant seem to get that damned cellular network data option...Goto cydia and download
      Supreme Preferences. Enable with winterboard. Goto...Settings>>Supreme Preferences>>Applications>>Phone>>Cellular Data Editing(Switch To ON>>Cellular Data Network
      Hasnt been a post here in almost a month but to those just trying it
      Your Welcome

    • jimjim Posts: 128
      via Wordpress

      I have tried all methods and they all fail after a brief period of time. Actually, now, none of them work anymore. I still have the software capability, I just get the Red ! indicating failed message. I worked previously, so I have no idea what changes.

    • jimjim Posts: 128
      via Wordpress

      Rah,

      The camera icon will only appear when the network fields are populated for MMS:
      APN: wap.cingular
      Username: [email protected]
      Password: CINGULAR1
      MMSC: mmsc.cingular.com
      MMS Proxy: 66.209.11.32
      MMS Max Message Size: [Blank]
      MMS UA Prof URL: [Blank]

      Still, mine failed after a few days. AT&T?

    • JonJon Posts: 116
      via Wordpress

      WOW. after fiddling with mms for 3 hours, this finally did it!! the most important step was to visit the mymedianet website with my SIM plugged into my old phone (so that ATT thinks that i'm using a "compatible" medianet phone). once you verify the code they text to you, MMS works flawlessly. THANK YOU STEVEN M!! i'm like a happy child today.

    • kamilskikamilski Posts: 1
      via Wordpress

      I can officially confirm that this DOES work. After spending some time on the phone with AT&T they changed my data plan to a cheaper one and everything works great!

    • dylanrauhdylanrauh Posts: 1
      via Wordpress

      same as mine, i dont kno what to do? i followed all of the directions, and it gives me an error. HELP!!!!!!!

    • Bret HBret H Posts: 1
      via Wordpress

      I was pulling my hair out trying to get both MMS and Tethering to work on my 3Gs. Finally with just the ipcc file from this article and setting:



      MMSC to " rel="nofollow">http://mmsc.cingular.com

      MMS Proxy to wireless.cingular.com



      Then reboot!

    • vernvern Posts: 2
      via Wordpress

      Didn't work for me... :(

    • leoleo Posts: 47
      via Wordpress

      for the no working voicemail... you can fix it with....


      go to Stetting>General>Network>Cellular Data Network and under Visual VOicemail make it look exactly like this...


      APN acds.voicemail
      Username leave it blank
      Password leave it blank

    • artmanpartmanp Posts: 9
      via Wordpress

      I got mine to work but I have the same problem alot of you have. After about 10 mins att switches back to iphone and my mms stops. I have swirly mms2 but i dont have the right settings for swirly.does anybody have them? Or kknow how to block att detecting I am back on my iphone and blocking my mms.

    • artmanpartmanp Posts: 9
      via Wordpress

      If you have the swirly mms2 settings can you email them to [email protected] Thanks again

    • GumbyGumby Posts: 4
      via Wordpress

      on my 3gs i have the following swirlymms2 settings that have been working for me for about 2 weeks now:

      mmsc: http:/mmsc.cingular.com
      proxy: wireless.cingular.com:80
      apn: wap.cingular
      username: [email protected]
      password: CINGULAR1

    • RlRl Posts: 19
      via Wordpress

      Just tried this. Tethering works but MMS doesn't. The messaging screen allows the sending of pictures but it will always fail and give the red exclamation symbol

    • BnigBnig Posts: 1
      via Wordpress

      Would anyone mind telling me EXACTLY what to enter into CMD or what problems there may be with it? I have windows vista 64-bit and the cmd just won't work, it says the program is not recognized..

    Sign In or Register to comment.