Yalu Jailbreak for 6, 6s plus

Since the new Yalu jailbreak is allegedly buggy, and Apple just released 10.2.1, if one wants to Jailbreak should the do it before Apple quits signing 10.2 (my current version)?