Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Popular Discussions

    Step-by-Step Guide to Downgrade from iPhone Firmware 2.2 to Firmware 2.1

    ^_^^_^ Posts: 4,429
    via Wordpress in iPhoneHacks.com
    imageStep-by-Step Guide to Downgrade from iPhone Firmware 2.2 to Firmware 2.1

    One of the most common problems after Apple releases its the latest firmware update for the iPhone is that some users who have jailbroken their iPhone end up accidentally upgrading it. So when Apple released iPhone firmware 2.2 on Thursday night, quite a few readers ended up accidentally upgrading their...

    Read the full story here

    «13

    Comments

    • MarkMark Posts: 267
      via Wordpress

      I am one of those people who accidentally upgraded to 2.2 without knowing I would no longer be able to use a Proxy-SIM with it after the upgrade.

      I tried doing the Firmware rollback to 2.1 and it was unsucessful. The rollback completed, and I got the 1013, but then iTunes would not recognize the firmware with a message saying I needed to restore my iPhone to the original settings. So I restored back to 2.2 with iTunes and now back where I started. I even restarted iTunes and the same thing.

      If there are any further steps needed to get iTunes to recognize your 3G iPhone after you rollback the firmware to 2.1 then please post them here in case I did something wrong after the rollback. Thanks.

    • iPhoneHacksiPhoneHacks Posts: 2,315
      via Wordpress

      @Mark,

      Thanks for your feedback.

      I guess you are using proxy SIM (hardware method) to unlock iPhone 3G, this is uncharted territory for us.

      However, we are not sure if the baseband update (which does not get downgrade using this method) is causing this issue or its the latest version of iTunes (8.0.2).

      You can probably try using an older version of iTunes to see if it helps. You can download an older version of iTunes from this link:
      http://www.oldapps.com/itunes.htm

      We didn't have any issue with an iPod Touch so we are guessing that Apple has made some changes with the baseband update in firmware 2.2 to prevent the hardware method to unlock iPhone 3G.

    • jackjack Posts: 149
      via Wordpress

      Mark, same thing with me, I'm not sure, but I think I read that if you delete some file in some folder that this problem will go away if you try it again. Only I can't find the link where this was suggested.

    • jackjack Posts: 149
      via Wordpress

      btw, I"m not using the "proxy SIM (hardware method)" itunes 8.0.0.35

    • DancingkingDancingking Posts: 1
      via Wordpress

      I success to restore my 2G iphone to 2.1 after accidentally upgraded to 2.2. This method is work. I can use my iphone again. Thz God¬

    • iPhoneHacksiPhoneHacks Posts: 2,315
      via Wordpress

      @Dancingking,

      We are glad to hear it worked for you, thanks for your feedback.

      @jack,

      Thanks for clarifying. We are assuming you were trying this with an iPhone 3G.

      We will let you if you there are additional steps for iPhone 3G users.

    • iPhoneHacksiPhoneHacks Posts: 2,315
      via Wordpress

      Folks,

      We have just unpublished some of the comments as they were out of context.

      cheers!

    • webterractivewebterractive Posts: 2
      via Wordpress

      I'm not looking to unlock the iPhone since I had it working well with a TurbSim, but now stuck with 2.2 I'm trying to downgrade to at least 2.1.

    • RonnyRonny Posts: 6
      via Wordpress

      I get the same error after downgrading it to a 2.1 itune wouldn't recognize it. I'm using iphone 3G 16Gb any suggestion?

    • DereckDereck Posts: 16
      via Wordpress

      Even if you can downgrade from 2.2 to 2.1, I believe that the modem version remains the same, which means that you are taking risk to make your iphone to ipod.

      Obviously I haven't try this myself, coz I dare to upgrade mine to 2.2. As I am waiting Dev Team to release their tool so that we can safely upgrade to 2.2 without changing the modem version, in hope that the soft-unlock become available on 2.1

    • DereckDereck Posts: 16
      via Wordpress

      To: webterractive, can you still use your turbosim with 2.2??

    • GreyhameGreyhame Posts: 1
      via Wordpress

      I have a Rodgers 3G that was working with Tmobile just fine with a Proxy SIM, but I upgraded to 2.2 and now it does not work and also I could not downgrade (Error 1013 and then it goes no further)

      I use the Phone in Canada when I am there and wanted to use it with Tmobile in USA. I have 2 numbers and pay for both. It doesnt seem unreasonable to me to allow one to pay for both services and use one phone...I can do this with other phones.

      Please find a work around, or it will be over to a Tmobile G1 who always unlock their phones for loyal customers.

    • iExpertiExpert Posts: 1
      via Wordpress

      Can someone post information regarding iPhone 3G?

    • DavidDavid Posts: 225
      via Wordpress

      I accidentally upgraded my iPhone 3g to firmware 2.2 and the proxy fix would not work. So I tried restoring per the instructions and I got a "Error 1013" and I thought I was stuck.

      Then I pondered a bit and tried something different. I downloaded the latest version of Pwnage which 2.1 and I create a custom firmware so I could jailbreak the iPhone.

      After doing the steps in Pwnage I forced myself into DFU mode which they walk you through. iTunes then started up and it recognized the iPhone in "Recovery Mode" and I chose the custom 2.1 firmware that Pwnage had create.

      Voila! It worked and now I am back to 2.1 firmware on an iPhone 3.g hacked via proxySIM to work on the T-Mobile network.

      Only 1 Question: I have yet to figure out how to setup my Edge settings. Any ideas? I have the $20 T-Mobile Edge plan but I do not know how to get it to work.

    • BillBill Posts: 153
      via Wordpress

      i dont get how to ignore the error massages. It wont work when i restore to 2.1. it will almost finish and then i get the error (1013) and it stays in recovery mode.

    • ganjaganja Posts: 1
      via Wordpress

      I accidentially updated to 2.2 and did the downgrade to 2.1 the first time i got the error 1013. The second time I got it again but after a restart of my iphone it worked pefectly in 2.1 then i just had to jailbreak it and i thougt everything wold work normal again. I work with turbosim and i entered the pin but now it gets strange it is not possible to connect to my network no matter what it does noch connect to my carriers network i hate this

    • yankiiyankii Posts: 51
      via Wordpress

      im having the same problem as ganja....

      i upgraded to 2.2... then downgraded to 2.1 successfully, but, im not able to get any service... if i reboot my iphone, or remove and insert my sim card, it will get signal for like 5 seconds, then drop and go back to the No Service. I have tried everything.

      I read somewhere that the 2.2 upgrades the baseband, and im guessing that downgrading to 2.1, makes it uncompatible and does not work.

      While i was trying to get a fix, i noticed that the jailbreak for 2.2 came out... and since i couldnf figure out how to fix the No Service in 2.1 problem, i decided to jump in and upgrade back to 2.2.

      Everything upgraded successfully, BUT, im still getting the No Service msg.

      What can i do to fix this?????????

      Thanks in advance!

    • bobbybobby Posts: 32
      via Wordpress

      I HAD A IPHONE 3G 2.1 WHICH I JAILBREAK IT. BY STUPIDITY I UPGRADE TO 2.2. I DID A LOT OF RESEARCH, TRY A LOT OF DIFFERENT TRICKS UNTIL I GOT HERE.

      THIS STEPS WORK GREAT FOR ME. I DOWNGRADED TO 2.1 AND JAILBREAK IT AGAIN.
      THANKS A LOT TEAM.
      ;-);-);-);-);-);-);-);-)

    • mtmt Posts: 8
      via Wordpress

      @ David. Hey, that sounds like you've found a real fix.

      Can you check that your modem firmware version was actually rolled back (earlier than 02.28.00)? As far as i know that's the main reason the upgrade stopped my turbo-sim from working.

      Also, if you could post up some slightly more detailed instructions for dummies like me that haven't used the Pwnage tools before.

    • MahaiMahai Posts: 1
      via Wordpress

      Hi Guys,

      M having exactly the same problem as above. Now my phone just pop up NO SERVICE. **** APPLE, letting lot of people suffer. Anyway, if anyone know how to get the phone signal back, please post as M using Turbo sim also. THx in advance. God bless u.

    • BasBasBasBas Posts: 1
      via Wordpress

      OH MY GOD...

      I have the same problem "No Service" after accedantly upgrading my iphone 3g to 2.2.

      I tried everything including the new QuickPwn but with no luck still "NO SERVICE"

      i think it is the baseband issue.

      HELP HELP HELP pleas!

    • da GREATda GREAT Posts: 1
      via Wordpress

      i need help... new to this jailbreaking stuff.. after i jailbroke my iphone 3g it was running a bit slow so i went into the setting of the iphone and did restore to factory setting from the phone and it said it would take about an hour. now my phone is stuck with a black background with a pineapple sign in the middle. please help me figure this out. thank you. (i hope my phone is not useless now)

    • MarkMark Posts: 267
      via Wordpress

      Wow, in just 24 hours, lots of comments here. Good stuff.

      I think it is confirmed now that there is no benefit to rolling back the firmware to 2.1 since the baseband issue blocking use of Proxy-SIM / Turbosim cards has now been confirmed.

      What is confusing here though is it sounds like iExpert has managed to get his 3G iPhone working again after rolling back the firmware to 2.1.

      iExpert, can you please confirm on this again and what the status is of your phone at the moment?

      By the way, there is another detailed discussion on the subject here for those who are interested:

      http://www.everythingicafe.com/forum/iphone-3g/2-2-upgrades-with-3g-gevey-turbo-sim-39467.html

    • poorboy504poorboy504 Posts: 1
      via Wordpress

      I have also updated to 2.2 like a fool with out reading about it first. 8g 2g. i tried these steps and when opening to locate past firmware i dont see any at all. Am i looking in the right place? itunes/my documents?

      please help

    • MarkMark Posts: 267
      via Wordpress

      Old firmware versions need to be downloaded. They are not kept on your computer.

      For 3G you can go here. For 2G there is another site, but can't recall the link right now, sorry.

      http://www.spaziocellulare.com/ispazio/download-firmwares-iphone-3g/

    • iPhoneHacksiPhoneHacks Posts: 2,315
      via Wordpress

      @Mark,

      Thanks for link.

      @poorboy,

      We have provided the links in the post, here they are again for your benefit:
      http://appldnld.apple.com.edgesuite.net/content.info.apple.com/iPhone/061-5202.20080909.gkbEj/iPhone1,1_2.1_5F136_Restore.ipsw

      The Dev team have released PwnageTool 2.2.1, QuickPwn 2.2 for Mac & QuickPwn 2.2 for Windows for iPhone Firmware 2.2. Since you have the 1st gen/2g iPhone you might want to checkout this post rather than downgrading to firmware 2.1:
      http://www.iphonehacks.com/2008/11/jailbreakunlock.html

      cheers!

    • wardward Posts: 1
      via Wordpress

      To the guys that managed to downgrade an iphone 3G to firmware 2.1 How did you do that? just like Mark I tried doing the Firmware rollback to 2.1 and it was unsucessful. The rollback completed, and I got the 1013, but then iTunes would not recognize the firmware with a message saying I needed to restore my iPhone to the original settings. So I restored back to 2.2 with iTunes and now back where I started. I even restarted iTunes and the same thing. Putting the iphone in DFU mode did not help. To the guys that managed to downgrade please explain how, step by step!

    • CoryCory Posts: 8
      via Wordpress

      Hey guys I successfully downgraded to 2.1 and fixed my problem, which was that I had categories installed and lost a lot of apps. When I downgraded I had no signal and my heart dropped. I used quickpwn 2.1 to jailbreak and then restored to 2.1 with itunes. I got the error message 10XX. So then I used Itunes to upgrade back to 2.2 and it all works with all my apps. If you have any questions email me. [email protected]

    • hacker1hacker1 Posts: 1
      via Wordpress

      Hi,

      I did 6 2G iphones with 2.2 firmwares which I downgraded to 2.1. Unlocked/jailbroken them back to use with Tmobile.

      I do have 1 3G that I was able to downgraded to 2.1 from 2.2. Jailbroken it successfully but not able to get Turbo SIM to work again.

    • kingjorgekingjorge Posts: 1
      via Wordpress

      I recently upgraded my iphone 2g earlier today to 2.2 from the original release level firmware. Then I tried to run jailbreak, but jailbreak just sat there for a long while doing nothing. I finally just disconnected and tried to restart over the jailbreak process, but also failed. Then I tried to restore to the factory settings, not knowing what my other options were because I got scared and didn't want to lose all my iPhone customizations. But I did in fact lose everything that I had cutomized because I didn't sync before I upgraded to 2.2.

      My question is, before the upgrade to 2.2 firmware, I am sure the iphone did a backup on it own. Is there a way to restore back to that backup? I especially want the calendars, notes and contacts.

      I tried right clicking on the device in iTunes, but there's no backup there from prior to the 2.2 firmware upgrade. There has got to be something I can do to get back to that backup prior to the 2.2 firmware upgrade that I did earlier today.

      Any help would be greatly appreciate.

      Thanks.

    Sign In or Register to comment.