Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Popular Discussions

    iPhone Dev Team: Software Method to Unlock iPhone 3G to be Released on New Year’s Eve; Possible Fixe

    ^_^^_^ Posts: 4,429
    via Wordpress in iPhoneHacks.com
    imageiPhone Dev Team: Software Method to Unlock iPhone 3G to be Released on New Year’s Eve; Possible Fixes for DFU Problems with Mac OS X 10.5.6 Update [Updated]

    The 10.5.6 update for Mac OS X Leapord that Apple released yesterday prevents your Mac from recognizing your iPhone in DFU mode, making it impossible to jailbreak and/or unlock it using PwnageTool or QuickPwn. The iPhone Dev Team believes that it is due to a kernel bug rather than a...

    Read the full story here

    «1

    Comments

    • benben Posts: 235
      via Wordpress

      Does this not apply to the people updated to the 2.2 firmware with the 2.28 baseband? I hope it does. It would be a great Christmas/ New Years/ Chanukah present.

    • TomTom Posts: 314
      via Wordpress

      I hope it can unlock the new 2.2 firmware with the 2.28 baseband too. Just a side note I am set to be laid off on the 31st. So if the benevolent Iphone Development Team can find it in their hearts to help me unlock my Iphone, it will make unemployment a little more bearable.

    • iPhoneHacksiPhoneHacks Posts: 2,315
      via Wordpress

      @Tom,

      Sorry to hear about the job loss, these are indeed unprecedented times. Hope something works out for you soon.

      @Tom and @Ben,

      Unfortunately, based on iPhone dev team's comment it doesn't look like it will support the 2.28 baseband.

      However, I will keep you folks posted if we hear there is some good news on that front.

    • AshAsh Posts: 40
      via Wordpress

      I don't understand, why the dev team does not have a baseband downgrade tool to downgrade the baseband, just like they have for the iPhone EDGE. It sure would be a Merry Christmas if they can come up with a tool for us to downgrade the baseband.

    • biotitanbiotitan Posts: 0
      via Wordpress

      WHATS THE POINT??? IT CANT UNLOCK THE 02.28.00 MODEM FIRMWARE!!!!!

    • EdEd Posts: 110
      via Wordpress

      What if we have the jailbroken 2.2 firmware provided by the dev team (no base band update), will it work with that?

    • iPhoneHacksiPhoneHacks Posts: 2,315
      via Wordpress

      @ed,

      If you have used the method which preserves the baseband firmware and only updates the OS then you should be able to unlock your iPhone 3G.

    • cpennercpenner Posts: 10
      via Wordpress

      @biotitan,

      Press the button to the left of 'A' key...

    • SamSam Posts: 218
      via Wordpress

      So does it mean that we are still stuck with this 2.28 and no way to downgrade it? I mistakenly updated it and now i am stuck. Please tell us if there is any solution for this

    • Giga-ByteGiga-Byte Posts: 1
      via Wordpress

      Why do we have to wait so long for the release. Lets get it going NOW

    • Kray-ZKray-Z Posts: 85
      via Wordpress

      You know what is gonna suck for me and a whole lot of ppl? That soon when we buy the iPhone it will already have the baseband updated and there will be nothing we can do about it. I would love to get it before they sell it updated but i way to broke right now. Is there a way we can buy it in the future with the old baseband without relying on ebay, craigslist, the sort? as im an existing AT&T customer and plan to use my upgrade discount.

    • anonyanony Posts: 3
      via Wordpress

      What the **** is wrong with you people? Can you not read? It clearly states that it supports the 2.1 baseband firmware and not the 2.2. It also illiterates the fact that you were warned not to update in the event that you wanted to later unlock.

      Sam - You are fucking retarded. It will be released when it is finished. You want it sooner? Why not help contribute in someway you fucking ungrateful moron.

      My thanks to the dev team for their hard work and generosity.

    • DaltonDalton Posts: 1
      via Wordpress

      Ok so what if my 3G is already jailbroken, if I do the soon to be available software unlock will I lose all my apps and start doing all my software installs over again? If so would using an unlock Sim solve this? Thanks idev team, great stuff!

    • ScottScott Posts: 164
      via Wordpress

      I can report that the problem with DFU mode and OS 10.5.6 is not universal. I upgraded to the new OS yesterday and had no problem putting the phone into DFU mode and itunes recognized the phone just fine. My phone is already jailbroken, perhaps that makes a difference.

    • kDubkDub Posts: 48
      via Wordpress

      Anony..little harsh, don't ya think?

    • via Wordpress

      Nice to know this..

      Can i put your content on my blog ...?

      With a link back ..?

      Regards

    • andresandres Posts: 23
      via Wordpress

      Will I be able to unlock my Iphone 3G 2.1 by jailbreacking it with Quickpwn 2.1 because I dont own an apple computer to use the other program????

    • SamSam Posts: 218
      via Wordpress

      Well i can contribute you ****. I do not have any problem with that but where the **** am i going to contribute and i did not ask you to build it for me or for anyone else so stop being a **** Anony. All the hard work come from dev team and what are you moaning about anyway?

    • benben Posts: 235
      via Wordpress

      A short response to Anony:
      I know it is nice to feel like a big tough guy from your computer chair in your lonely home. I am also sure you are the king of your friendless world where nobody challenges you for your childlike tantrums. I, and I am sure many other people, would appreciate it if you could tone down your rude and inconsiderate comments. We all appreciate the hard work the Iphone Development team is doing. I don't think you will encourage people to contribute to the cause by belittling them and calling them names. Let's be constructive. How about a list of ways we can assist the Iphone development team...

    • benben Posts: 235
      via Wordpress

      I guess my message was a few minutes too late. Sorry all.

    • lawlaw Posts: 2
      via Wordpress

      Hmm, My Macbook Pro (bought last year) was in repairs this past week and they had to swap out my logic board. Will this affect the PwnageTool... or it's the newer Macs that will be affected? Any input will be great!

    • therandalltherandall Posts: 1
      via Wordpress

      If you have access, get the Iphone 3G from Singapore. Sold unlocked by the exclusive carrier, Singtel. Works with any sim.

    • LitospowerLitospower Posts: 0
      via Wordpress

      I do have a NewBook released early Novemeber this year operating on Mac OS X 10.5.5 ! The Pwnage Tool or QckPwn doesn't work on it. I did even try doing a partitition on harddrive and use Windows (bootcamp), but this didn't work either. iTunes does not recognize iphone in DFU mode and gives an error at the end. Any ideas what I can do ?

    • richiprezarichipreza Posts: 0
      via Wordpress

      to late i upgraded to 2.2 b4 i even see the message i can still use cydia but cant get free apps like touchgrind i just get maessgae it couldnt be opened, damn that will teach me

    • yvetteyvette Posts: 3
      via Wordpress

      i have the unlocked iphone 3g. it's fom dubai but i've learned through the part number that it is from singapore. i haven't upgraded it to the lastest software fearing i might lock it again because i have read in some forum that when they did, it got locked again. well, what do you think?

    • iKnewUseriKnewUser Posts: 1
      via Wordpress

      2.28 Solution:
      You can keep using your phone. If you accidentally upgraded to v2.2 & 2.28.00, there IS a solution. You can JailBreak the phone using QuickPWN, then buy a turbo-SIM. I just bought the GEVEY 2.2/2.28 SIM on Ebay. I used one earlier and it worked fine. This lets you use your phone, until a software unlock is available.

      Regarding the Flame by @Anony on Dec. 16: I agree it was crude & rude, but I was also secretly happy to see someone "policing" the lazy people who just post "wishes" for others to help them. Those posts = spam in my opinion.

    • johnny appleseedjohnny appleseed Posts: 2
      via Wordpress

      First of all let me thank with high regards the dev team for all their hard work for helping us poor people that don't have $30 extra dollars a month for a data plan to still use an iphone. unfortunately i bough an iphone 3g version 2.2 jailbroken ( not unloked ) from ebay and i thought all you had to do was put a turbo sim in it and WALLA it would work. I beleive i'm wrong I did put the turbo sim in and at&t came up with all bars ok. But 3 hours latter i had no service on it. I just read that someone bought a gevey turbo sim and put it in their ( 3g ) and it worked. could this work on my iphone? maybe the turbo sim i bought was no good or was it that at&t found out i had an iphone when i used my wifes old phone sim and they blocked it? i'm lost in this iphone 3g world all i wanted to do is buy my wife an iphone and let her use it as a phone/wifi computer she wont let go of mine. If anyone can help thank you

    • ShaQ1nJShaQ1nJ Posts: 22
      via Wordpress

      Johnny Appleseed:

      I highly suggest you backup everything on the iPhone and restore the iPhone. After that, jailbreak the phone again and put the TurboSim in again. Maybe your iPhone was incorrectly jailbroken?

    • ShaQ1nJShaQ1nJ Posts: 22
      via Wordpress

      Sorry Johnny, I also found this:

      "Just want to share this: if you use turbosim to unlock your iphone 3G, you can update your phone to v2.2 using pwnagetool custom ipsw. By doing this, you have preserved baseband version which will not effect the way your trubosim works, otherwise you have either to update the firmware of your turbosim (if it is available) or buy a new one which supports v2.2 in the near future. I have personally tested it. I have updated my iPhone 3G to v2.2 using pwnagetool and my turbosim is still working."

      You may need to buy a new, updated TurboSim that supports 2.2.

    • karlkarl Posts: 113
      via Wordpress

      hey guys. ots new years eve so where is the unlock? what time today will it be released? or is it late

    Sign In or Register to comment.