Simple Steps to Re-enable DFU Mode in Mac OS X 10.5.6 to Jailbreak and Unlock iPhone

^_^
^_^ Posts: 4,429
via Wordpress in iPhoneHacks.com
imageSimple Steps to Re-enable DFU Mode in Mac OS X 10.5.6 to Jailbreak and Unlock iPhone

The 10.5.6 update for Mac OS X Leapord that Apple released earlier in the week prevented Mac from recognizing iPhone in DFU mode, making it impossible to jailbreak and/or unlock it using PwnageTool or QuickPwn. The iPhone Dev Team had provided some fixes for the DFU problems which needed some...

Read the full story here

Comments

  • duluen
    duluen Posts: 16
    via Wordpress

    woot! this works great. I used it on my new macbook pro (late 08) with 10.5.6 installed and can now use dfu mode!!! Thank you so much!

  • droe
    droe Posts: 1
    via Wordpress

    I installed 10.5.6 on a MacPro, Had to restore phone and used Quickpwn and had no trouble getting into to DFU mode without the hack !

  • Dennis Burton
    Dennis Burton Posts: 1
    via Wordpress

    Just ran this, got to the point of where i put my password then nothing happend....not sure whats wrong im new mac users

  • Michael
    Michael Posts: 316
    via Wordpress

    I went through a Lacie hub, works ok.

  • Sam
    Sam Posts: 218
    via Wordpress

    I used this hack on the newest MacBook Pro 10.5.6 and after the hack I could not use WiFi Apple talk? I couldn't transfer files from my old mac to my new mac any more. I checked permissions and there were problems there so I'm gona see it fixing them helps.

  • Jimmy2tImz
    Jimmy2tImz Posts: 1
    via Wordpress

    This app completely f-up my New Macbook Air. (Which apple kindly gave me last week to replace my 1st gen mac book air that required multiple repairs).

    DANGER WHEN RUNNING " Automator program Fix_DFU_10_5_6" (BE WARNED)

    After re-boot. the Keyboard, trackpad and USB. Would not function.

    Luckily i have a recent backup of the entire hard drive. And was able to connect to my Air using another mac using Screen Sharing.
    Then I just restored the folowing folder back to its original state. From my recent backup.

    System/Library/Extensions

    i also replaced this file to.

    System/Library/Extensions.mkext

    Its a drastic Measure but it worked, With out even rebooting.
    I hope this helps for anyone who suffers a similar calamity. If you do ot have another mac. Find some one who does, otherwise your otta luck.

    At the very least make a copy of this folder and file before you attempt this. Safer still use a usb hub to allow iTunes to recognize your iPhone DFU mode.

    Marry Xmas to all.

  • ben
    ben Posts: 235
    via Wordpress

    I need the 10.5.6 files, it messed up my USB files. Can anyone post a link to the files???? or e-mail a link???

    themustangmaniac(a)hotmail.com

    Ben

  • yutalee
    yutalee Posts: 1
    via Wordpress

    I alos need the 10.5.6 files. This made my mbp's keyboard and trackpad die.
    please help me.

    [email protected]

  • Jared
    Jared Posts: 67
    via Wordpress

    Thanks for the comments. I was about to try this but now Ill avoid it like the plague.

  • October
    October Posts: 1
    via Wordpress

    Mine did nothing after the password too, there was a little thing going in the bar at the top of the screen saying stuff, but then it went away and nothing, no restart, no warning...

  • Enigmafan420
    Enigmafan420 Posts: 4
    via Wordpress

    Used it on 2 Mac Minis and it did the reboot. All USB devices are working-I haven't actually tried to see if DFU works or not-I don't need it right now.

    No ill affects on Mac Mini though :)

  • stan-çb
    stan-çb Posts: 1
    via Wordpress

    i had the same proble keypad and mous unedetected
    luckely i had port 22open i loged on the macbook with my iphone and activated vnc server then i used jaddu to control the computer... i'm still trying to repare it BTW
    sorry fot my writing ... lots of mistakes

  • stan69b
    stan69b Posts: 50
    via Wordpress

    i finally got it to work... i tried to rebuild the kextcach using terminal and it didn't work so i tried to use the programe and after 10times it finnaly asked me for admin password and told me that it was rebuilding and needed to reboot
    it took me 4houres lol i'll advise you not to upgrade insted of having those kind of trouble see yyou guys i hope i helped anyone and thamks iphone dev team for all thos hackes and tips for iphone hacking et thanks iphone-hacks.com for updating news every day

  • ahsan
    ahsan Posts: 14
    via Wordpress

    Why it is needed to do that... something else should be done

    I am able to easily restore my iphone without entering in to dfu mode on any windows pc. they are always nearby....

    Tell me that is DFU so much needed that we play with kext files?????????

  • grega
    grega Posts: 3
    via Wordpress

    so correct me if im wrong, but why on earth would you try to load 10.5.5 kexts made for a non unibody mac on a unibody mac or new air? from my knowledge the new mack books require completely different kexts (or drivers for those of you only familiar with windows) because the hardware is different. and also i wouldn't trust software like this when you can just get a copy of kext helper if your too lazy to type in the commands in the terminal. and besides if your going to hack your iphone why not learn more about computers? and your phone itself to prevent yourself from making mistakes.
    ........dont use this if you have a new mac or air it will prevent you from using your hardware and make you reinstall mac osx......

  • Ron
    Ron Posts: 69
    via Wordpress

    my computer rebooted and everything but my itunes would retore it because it kept saying my usb device was low on power but my iphone i s fully charged. my iphone screen turned white and blank. help me please!

  • godiva31
    godiva31 Posts: 2
    via Wordpress

    Hi,

    i've same pbe with mouse and keyboard blocked. I've done kextcache -k or -u after boot cdrom and restore Extensions folder, but same pbe; i think it's a pbe in caches, do you have idea please ?

  • godiva31
    godiva31 Posts: 2
    via Wordpress

    Hi
    I've resolve my pbe :

    Insert cdrom 1 Macos DVD

    Start macbook with press key C (to boot on cdrom)

    Open Terminal (choose keyboard french hight right on screen)
    Delete Caches folder in

    ~/Library/Caches for account users

    /System/Library/Caches

    In Terminal do :
    cd /Volumes/Macintosh..HD/System/Library
    rm -rf Caches

    cd /Volumes/Macintosh..HD/Users/..../Library
    rm -rf Caches


    I've also delet file /System/Library/Extensions.mkext but i'm not sure i need to...

  • ami m
    ami m Posts: 1
    via Wordpress

    To all of you who struggle with this one
    It has a bug in it
    If you open Automator then the file
    On the bottom of the script it looks for the downloaded folder on the
    Desktop
    Change it to downloads
    If you ran this already and you have the backupfiles on the desktop
    run just that last script

    Also right after restart do repair permissions
    They are all messed up
    Good luck

  • nvy
    nvy Posts: 1
    via Wordpress

    My imac does not recognise my keyboard and mouse at the login screen after re-enabling DFU mode.

    Is there an alternative method of logging in without password or the need of a keyboard?

  • Mika
    Mika Posts: 1
    via Wordpress

    This script f**ked up my computer. Now mouse or keyboard are not working. Great...

    "Fortunately, volkspost over at Hackint0sh has put together Automator programm Fix_DFU_10_5_6 which achieves this with one mouse click (and also takes a backup of the original files)."

    So, how to back up these files? I am using my laptop with external drive now, and i can have access to my harddrive, and i can see Backup_IOUSBFamily_kext_10_5_6 folder.

    Can someone post instructions how to fix this?

  • tim
    tim Posts: 173
    via Wordpress

    Script stuffed up my computer as well - after rebooting, the keyboard and mouse are not working (so can't even log in). I've tried connecting external keyboard and mouse as well, however that not working either - anyone know how to fix this?

  • radiohead3
    radiohead3 Posts: 0
    via Wordpress

    I also tried this script.
    It stopped after entering the password and nothing happened...

    BUT

    Now it's working. I could jailbrake it.

    In the last 30min I didn't recognized anything special or incorrect about my Macbook.

    Thanks

  • Bang
    Bang Posts: 7
    via Wordpress

    I would like to say THANK YOU THANK YOU THANK YOU I have been trying on this for about 10 hours on 2 different days and finally a solution... :)

  • ben
    ben Posts: 235
    via Wordpress

    seems to have worked for me but to be safe i am backing up everything before my next reboot. Oh yeah i have a Macbook pro not the aluminum one or the one before that. The last one without multitouch.

  • Brandon
    Brandon Posts: 86
    via Wordpress

    okay.. i tryed this but it doesnt get all the way to the end where it reboots my computer? why is it doing this?! ive been working on my phone for to days and the DFU is the problem!