Step-by-Step Guide to Jailbreak iPhone 3G running Firmware 2.2.1 using QuickPwn 2.2.5-2 (Windows)



  • Stargateonly
    Stargateonly Posts: 5
    via Wordpress

    Hi Adnan,
    I got the apple logo all the time after the jailbreak is done. I tried to reset it many times but of no avail. only finally that during the constant resetting of the power button that it starts to store. And that's where I restore back to my original state of 2.2.1 firmware setting.
    I have tried jailbreaking twice and same problem occurred with the Apple logo hangs there with 2 days of un-usable phones.
    Anyway, something must have gone wrong during the process. For now, my iphone is still not jailbreak.
    During restoring, you have an option to choose a new clean restore which restore everything in the set or restore back to your last sync stage.

  • iPhoneHacks
    iPhoneHacks Posts: 2,315
    via Wordpress

    Hey Raks,

    You can upgrade your iPhone 3G with firmware 2.2.1 using iTunes if you don't
    want to unlock it.

    You can then using QuickPwn 2.2.5-2 for Windows to jaibreak your iPhone 3G
    running firmware 2.2.1. You need .net frameworks installed on your computer
    for QuickPwn to work.

  • iPhoneHacks
    iPhoneHacks Posts: 2,315
    via Wordpress

    Hey Stargateonly,

    Here are some solutions/workarounds that seem to have helped some users
    resolve the issue you had reported:

    The way it worked for me is when stuck at boot logo i opened itunes with the
    phone stuck then put in recovery by holding home and power at same time till
    it shuts off like normal reset but keep holding them let go of power for 2-3
    sec dont let go of home though. Itunes should find it after 10-15 sec after
    letting go of power but still holding home. (same process quickpwn requires
    to jailbreak) Of course this requires a restore afterward so i dont know if
    this is the route you might want to take and i had to set up as new without
    syncing anything until after i jailbroke.

    Link for your reference:

    Well after many jailbreaks, and many hours stuck on apple logo, and many
    restores later, i found out what i was doing wrong.
    Well after every un successfull jailbreak, i would restore and sync all my
    things onto my ipod touch 2.2 again and than jailbreak and fail.. all over
    again 5 times. But today, i decided after restoring, i wouldnt sync anything
    so my ipod would be jailbreaked empty. I did it and it worked! My ipod
    started up normall after jailbreak. Now, i'm going to sync all my things
    back again.

    Link for your reference:

    As soon as the quickpwn steps were over...i disconnected the phone from the
    usb cable. restarted itunes, and then replugged my iphone again...i think
    that helped too after reading it somewhere.
    give it a go., it worked for me!!!!!

    Link for your reference:

    Please let us know if any of these methods helped resolve the problem.

  • 500modder
    500modder Posts: 5
    via Wordpress

    Ok so I went ahead and used QuickPwn 2.2.5-2 for Windows on my factory unlocked iphone. And it seems to have worked. I followed the directions above to a tee - except for one thing - in step number 3 of the jailbreak procedure it says "In the next screen, click browse and select the iPhone firmware 2.2.1 that you had downloaded in step 5 of the preparatory steps and click Open." But I had not updated my iPhone with this file (I had updated to firmware version 2.2.1 (5H11), modem firmware 02.30.03 through the update link on iTunes and backed up my iphone). So when I got to this stage quickpawn automatically selected the .ipsw file that was stored in itunes. I went with this selection instead of the downloaded .ipsw file as it seemed the more logical choice and since I wasn't trying to preserve the baseband anyway. It worked – and my phone is still unlocked!

  • concius
    concius Posts: 3
    via Wordpress

    i have tried several times to jailbreak my iphone without success. i have the ipsw from here but it will not restore on my iphone, i get error 1602. how can i restore with the ipsw from here?

  • Pipe
    Pipe Posts: 3
    via Wordpress

    I have bought iPhone yesterday from my friend. It is 5G77 and 02.28.00 and already activated. I tried to jailbreak the iPhone but unfortunately, I made a wrong process. I downloaded


    and tried to follow the procedure. Actually, I can skip to start at QuickPwn but I just hold SHIFT Key and restore my iPhone which was unnecessary....T_T
    Now, it's not fine because it shows that I have to insert an UNLOCK SIM to activate the phone but I didn't have it. So, is there any suggestion for my issue?

    Thank you

  • Amit
    Amit Posts: 40
    via Wordpress

    I have the exact same problem, the jailbreak completes successfully and the phone goes into reboot mode, it just never starts back up and stays stuck at the apple logo screen, no matter what you do, it doesnt go past this stage. One thing to note that i didnt check the "replace boot logs" while jailbreaking. Im on the latest 2.2.1 firmware and latest baseband 02.30.03. Please advise.

  • Sam
    Sam Posts: 218
    via Wordpress


    I have updated the firmware to 2.2.1 but can jailbreak it but cannot unlock it..can anyone suggest:)

  • passerby
    passerby Posts: 16
    via Wordpress

    izzit true that once i jailbreak my iphone, the warrantly is void?

  • Raks
    Raks Posts: 2
    via Wordpress

    hey how do i go back to version 2.2 ??? im using windows xp.


  • iPhoneHacks
    iPhoneHacks Posts: 2,315
    via Wordpress

    You can use this guide:

    But it will not downgrade the baseband. There is no method available to
    downgrade the baseband.

  • leo
    leo Posts: 47
    via Wordpress

    Hiiii Guys.....
    I was reading thorugh your comments trying to find a solution for my jammed iphone,was trying to jailbreak it but didint go through from the first time,,then i tried a few things and it wroks fine what i did is :

    1- you must restore you iphone to the factory setting state(connect it to the ituensin the duf mode and click restore and update and its gna take about 10 min

    2 the screen of activation ll appear then you must activates it and connect it to the itunes and choose a a NEW PHONE ...and UNTICK all the SYNCH process all of it !!!!
    3-retsrat your pc and open the quickpwn tools directly b4 anything else ,,and continue the jailbreak process

    hope it ll go easly like mine

    have a good jailbreaking all .....

  • Ricky
    Ricky Posts: 33
    via Wordpress

    hi i have an iphone 3g gb running 2.2.1 jailbroked by quickpwn. cyeverything has been running fine until this morning when cydia wont start. It opens, then says loading data then it closes???

    i have tried restarting the phone, but still does not work??

    could I run quickpwn again? or will that delete all of my data?


    via Wordpress

    Hi Dear,
    Does any body knows when dave team will released the unlocking for v2.2.1 base 02.30.03 i made mistake and upgrade my iphone and change the base band aswell is thier any way i can downgrade the base band please help me thanx

  • iPhoneHacks
    iPhoneHacks Posts: 2,315
    via Wordpress

    Hey hasee,

    Dev Team have not mentioned if they plan to unlock baseband 02.30.03. So I
    guess its anybody's guess.

    Stay tuned here at iPhone Hacks, we will keep you posted.

  • Ria
    Ria Posts: 3
    via Wordpress

    have you figured this out?

    i have the same thing =(

  • David Smith
    David Smith Posts: 1
    via Wordpress

    I have an iphone 3G Version 2.2.1 (5H11) with a Modem FirmWare 02.20.03. Will the jailbreak work successfully if I use QuickPwn 2.2.5-2? or do I need to use QuickPwn 2.2.1? I am on AT&T and will like to continue with my same carrier with the same service, should I take the sim card out while I am jailbreaking? or it doesnt matter?

  • CROCK3
    CROCK3 Posts: 1
    via Wordpress

    APPLE logo will not go away, and iTunes will not allow me to restore iPhone after I Jailbroke. It keeps giving me 2 vibrating tones about every 5 mins. Any help is greatly appreciated!

  • nanoBLAST
    nanoBLAST Posts: 2
    via Wordpress

    Works Absolutely fine for me... just jailbroken my £G with 2.2.1 firmware, and everything is perfect... and I even noticed it works faster than before

    Tap Tap Revenge 2 was lagging even with easy tracks and now it runs smoothly even with extreme tracks

    Perfect job :D

  • moey
    moey Posts: 1
    via Wordpress

    tryed it the first ttym wrked flawlesley just make sure u keep hol dof home button dnt let go wen asked to
    a must for everyonee

  • Aldo
    Aldo Posts: 2
    via Wordpress

    I jailbroke it with quickpwn 225 & all that....
    the apple logo keeps showing up i did it and followed everything and it doesnt unfreeze or so.... please help do i have to download the other ipsw file or what i have done it again like you say a zillion times thx

  • flip08
    flip08 Posts: 1
    via Wordpress

    thank you so much for the tut. it worked!!! just like some ppl here said, make sure ur iphone has nothing (music, vid, apps, etc.) it worked like a charm for me! no problems what so ever. I was scared to jailbreak at first, now i'm glad i did! thanks guys

  • jack
    jack Posts: 149
    via Wordpress

    I tried and it worked 1st time. Thanks very much. I got stuck at Apple logo for about 30-45 minutes. May be I have lots of Apps that's why it took so long. After I hear cling-cling sounds as if windows detects something, i turned on iTunes. iTunes froze about 5 minutes then iPhone is back to normal....Yeahhh!!!

  • :)
    :) Posts: 3
    via Wordpress

    mine jailbroke succssfully. :) thank you so much!

  • bobby
    bobby Posts: 32
    via Wordpress

    Tried to jailbreak under Mac OS and everything froze up. Used Bootcamp and tried to jailbreak under Windows XP and everything went just fine. Please forgive me Steve.

  • Lee
    Lee Posts: 153
    via Wordpress

    To all those suffering from the apple / pineapple logo freezing-on-reboot problem:

    You MUST restore to 2.2.1, even if the phone / touch already has 2.2.1.

    I made this mistake. You must restore, THEN jailbreak.

    via Wordpress


    I picked up my iphone today and i am trying to jailbreak it but having some issues, itunes says i am running 2.2.1 5h11 i have followed your guide and have downloaded the relevant firmware and this is saved as a zip file, when i use quickpwn it does not allow me to select the file, when i change it from zip to ipsw it allows me to select the file within quickpwn but gives the following error message teh ipsw file you have chosen does not match any firmware version quickpwn supports yada yada.

    Any help would be gratefrully appreciated...

  • dave
    dave Posts: 389
    via Wordpress

    whenever i go to step 2 of the actual jailbreaking process i click the blue arrow and get this message

    "To enable just-in-time (JIT) debugging, the .config file for this
    application or computer (machine.config) must have the
    jitDebugging value set in the section.
    The application must also be compiled with debugging

    i have no idea how to do this haha help

  • Andreas
    Andreas Posts: 5
    via Wordpress

    Works like a charm! I just did everything they told me to do, and when it was done, I loaded the backup of my phone I took earlier. Tnx :D

  • SuWoo
    SuWoo Posts: 8
    via Wordpress

    i dont know what you dudes are talkin about, the apps work fine with the jailbroken 2.2.1