HELP NEEDED - IPAD 4th gen stuck on APPLE logo after jailbreak

Recently bought an apple ipad 4th gen 128 gb gsm model. It was on 7.0.4 version. I just thot of jailbreaking it. Downloaded the latest version of evasi0n from its site and started the procedure. Everythin went on smoothly. In the second step after jailbreaking the ipad I also pressed the evasi0n icon on ipad.
After getting the final message on evasi0n that jailbreak procedure is completed the ipad rebooted and since then the ipad is stuck on the apple logo.
I tried a no. of time to manually upload the 7.0.4 manually after downloading the custom 7.0.4 gsm firmware from various sites, but i always get the message that the firmware is not supported.

Please help.


  • The firmware won't be supported as it is not the latest iOS release...since iOS 6.1 apple have stopped downgrades/re-installs of older versions.

    Have you tried hard resetting (hold down the home and power buttons together until the apple logo disappears then re-appears).

    If not try plugging into the PC and re-running evasi0n installer.

    If neither work I'm afraid its gonna be a Jailbreak free option by upgrading to 7.1