Simple Hack to Enable Tethering on iPhone OS 3.0



  • Alex kordon
    Alex kordon Posts: 1
    via Wordpress

    My phone has 3.1 software how do I go back to 3.0 as it is not working with 3.1 cheers alex

  • Mame4iphone
    Mame4iphone Posts: 1
    via Wordpress

    Highwind, could you point us to a tutorial on how to set up VPN to hide what is being transmitted. Right now i'm using PDANet and could MyWi if need be.

  • TWC
    TWC Posts: 1
    via Wordpress

    Tethering worked perfectly. Using it right now to post this also. I'm using a 16g 3Gs with 3.0.1 on it. I may be having that voicemail problem it mentioned. I'll have to test it further once my roommates get up. Otherwise it auto-connects through USB as soon as I flip the toggle to on. Great app!

  • Mina
    Mina Posts: 1
    via Wordpress

    I just tried this on my iPhone 3G and after installing the feature and pressed Done. I couldn't find "Tethering" under general on my phone.

    Can anybody else confirm if this feature still works or not?

  • JayeDee369
    JayeDee369 Posts: 30
    via Wordpress

    Thank you Nate. Unfortunately, I think Apple clamped down on the tethering because I tried it and the tethering screen didn't show up. I still show appreciation because without you guys hacking the crap outta the iPhone, I would never be able to enjoy the other good stuff you guys crank out. Thanks

  • pablito
    pablito Posts: 1
    via Wordpress

    Worked perfect. Thanks for the info

  • Anthony
    Anthony Posts: 66
    via Wordpress

    yes it is true. doesnt work for optus australia either. the internet tethering option just disappears.

  • Mikey
    Mikey Posts: 24
    via Wordpress

    This will not connect to the internet and it is not working 4 me, i need help.

  • David
    David Posts: 225
    via Wordpress

    Tethering does not show up on AT&T in the US on a 3Gs.

  • Devistation
    Devistation Posts: 1
    via Wordpress

    i accidently upgraded to 3.1.3 and it disabled my tethering option has anyone found a solution to this problem??? im devistated!

  • Joe
    Joe Posts: 450
    via Wordpress

    Tried it but message says cant dowload the format . No window with the option to install . Using 3.0.

  • akatsukiiub1
    akatsukiiub1 Posts: 2
    via Wordpress

    I didn't do it yet but i think it ll work cause all ya think so. tryin it out on my iphone 3gs 3.1.3 32 gb

  • akatsukiiub1
    akatsukiiub1 Posts: 2
    via Wordpress

    9/11 bad luck eh i wouldn't be surprised

  • tanka
    tanka Posts: 1
    via Wordpress

    So, when I try download, the screen says Invalid Profile. It also says profile format not recognized, does anyone understand what this means? I have the Iphone 3gs

  • Collins
    Collins Posts: 1
    via Wordpress

    I have 8gb 3g and the tethering hack itself won't download. I has this program before and then updated. Please update again. I've tried multiple things. Still won't install.

    via Wordpress

    Will this work with os 3.1.3? Is there any problems?

  • Cassie
    Cassie Posts: 1
    via Wordpress

    I tried to download this but when I go into settings general network no Internet teathering option comes up. Help!!!

  • Thanks this method worked great :D

  • Luis
    Luis Posts: 67
    via Wordpress

    If anyone has an iPhone 3G running 3.1.3 that is not Jailbroken and has lost the tethering feature since upgrading to firmware 3.1, welcome to my world! Here is what I did to get it working again.

    First off, I followed the steps found on this link to downgrade my iPhone 3G from 3.1.3 back down to 3.0.1:

    and here is the the reply I posted on benm's site:

    Ok, so I have Tethering again! However I don't know how it's working because my baseband is ICE2-05.12.01 still. Here is what I did: I have an iPhone 3G that was running firmware 3.1.3, with it's baseband upgraded to 05.12.01 as noted above. I took wigginsbe's advice and used redsn0w (redsn0w-mac_0.7.2 to be exact) to jailbreak my phone to install Cydia. I hoped to downgrade my baseband to 04.26.08 using Fuzzyband however, in the process, I found out that my bootloader version 05.09 is not supported by Fuzzyband, and therefore I cannot downgrade my baseband. The supported bootloader version is 05.08 in order to downgrade your baseband with Fuzzyband. So at this point, my iPhone 3G was now jailbroken using redsn0w 0.7.2, I installed Cydia, and subsequently installed Fuzzyband. Since I couldn't downgrade my baseband because of the reason explained above, I decided to restore my phone using one of my previous saved restores. I just so happened to have a backup of my iPhone 3G when it was running 3.0.1, so I used that. Once my iPhone finished restoring, what do you know, tethering was back, and working! I'd like to point out, that when I backed up my phone, I had benm's mobileconfig file already installed on my iPhone 3G, running 3.0.1, and had the mms configuration file from benm also to enable MMS on 3.0.1. So now at this point, my iPhone was restored, and tethering is working, but no MMS (even though my iPhone had it when I backed it up). I wanted MMS so I followed benm's MMS tutorial ( ) in order to enable my MMS again on my iPhone. After following the instructions in the link above, it broke my tethering. I could no longer see "Internet Tethering" in "\Settings\General\Network". I was very disappointed at this point. Although MMS was working. After a short time of google'ing, I found this link: . Although the instructions in that link call for iTunes 8.2 Pre-Release to be installed, I used the iTunes version already installed on my computer: iTunes version 9.2. I downloaded the tethering file: and started following instructions from step #5, and that was it, my tethering was now back! and MMS was working! I am happy again. I want to point out that when I check the cellular data ( \Settings\General\Network\Celluar Data Network ) all fields are blank, with the exception of the APN names, that is filled in ( wap.cingular ) for all three sections: Celluar Data, Visual Voicemail, and MMS. I didn't alter any of these fields as everything is working just the way it is, why fix it if it aint broke, as they say. The only thing I don't have is Video MMS, which I didn't have with my un-jailbroken 3G anyway, running 3.1.3. But I've done research and found that Video MMS on a 3G iPhone is possible but only on a jailbroken 3G iPhone running 3.1.3. So I might look into upgrading my Firmware version from what I have right now 3.0.1, to 3.1.3. But for now, I'm enjoying tethering and MMS, just like I had it before I upgraded to 3.1. Hope this lengthy explanation helps someone out.

  • Dasha
    Dasha Posts: 3
    via Wordpress

    i love this on my 3.0...wanna update but won't until we can do this on 4.0. is that an option yet (i dont wanna pay to do this the legit way)???? please let me if and when we can do this on 4.0!!

  • Sometimes I spent a few hours trying to tether my iPhone 3G to my mac and windows laptop. Tethering over USB works fine, but Bluetooth tethering fails to connect. Hope this works.

  • Scorpion
    Scorpion Posts: 3
    via Wordpress

    I don't know what happened but it seem that doesn't work with iPhones 4 , because as soon as I install the application the tethering string in my phone just disappear and only comes back when I remove the app that I installed . Help!

  • Sandmanlti
    Sandmanlti Posts: 1
    via Wordpress
    This does not work with my iPhone 4. Tethering tab is missing once profile is installed. Suggestions?