3Gs Won't Unlock tried EVERYTHING

Hello everyone, I have always been able to sort this kinda thing out myself, this is the first time that I find myself signing up to one of these websites asking for help. I really hope someone can give me an answer! I am trying to unlock and old baseband 3Gs that was previously locked to Orange. I had ios 6.0, installing ultrasn0w didn't work because I had the wrong baseband. So I installed ios 4.1, upgraded to ipad baseband and downgraded back down to 05.13.04. Jailbroke with redsn0w and installed ultrasn0w. This didn't work, I get no signal. Tried uninstalling mobile substrate and Ultrasn0w and restarting, still nothing. Tried turning off the device and reinstalling the jailbreak, remove sim, install mobile substrate, restart (not respring), install ultrasn0w, insert sim card, still nothing. Tried upgrading to ios 6 whilst keeping my baseband and I get iTunes error -1 . I also tried just keeping the iPad baseband and nothing!! please help I've been busting my head for the past 4 days!