iPhone Firmware 1.1.4 for Bug Fixes Released - Simpler method to Jailbreak iPhone Firmware 1.1.3 als

^_^ Posts: 4,429
via Wordpress in iPhoneHacks.com
imageiPhone Firmware 1.1.4 for Bug Fixes Released - Simpler method to Jailbreak iPhone Firmware 1.1.3 also works with Firmware 1.1.4

iPhone Firmware update 1.1.4 is out, the sixth firmware update since iPhone's launch. Based on initial reports the firmware doesn't seem to unlock any new features and is more for "bug fixes", however the good news so far has been that you can still Jailbreak iPhone running firmware 1.1.4 using...

Read the full story here



  • Leon
    Leon Posts: 20
    via Wordpress

    And for some reason i sware i was the first one to have this today. I went and restored my iphone but only to see that apple wanted to download 1.1.4 and i searched all over to see reports on this firmware and no1 had it haha. But i cant find anything new to the 1.1.4 update. The jailbreak worked just fine. Just installer checks your firmware and pretty much says you cant download anything because it needs 1.1.x=<4 Anyways im out of here. Enjoy everyone.

  • mickey
    mickey Posts: 54
    via Wordpress

    I have a valid ATT ACcount but none the less had to unlock My IPhone to get it to work after I Jailbroke it on 1.1.3 using the installer method. What steps will I have to use to upgrade to the new 1.1.4 softwear and just jailbreak it and activate through ITunes? PLMK Thanks For your time and site both are great Regards Mickey

  • cpuenvy
    cpuenvy Posts: 1
    via Wordpress

    Customize, SummerBoard, etc are broken because they look at your firmware version.

    ZiPhone rocks! Worked like a charm! BSD installed fine after the break.

    That is all I have on here as of yet. I can, however, see that "Make it mine" still has my phone named to what I named it.

    Also, it seems that the phone has 7.03gb free after the update. This is more than the phone had after the 1.1.3, on my end. Hopefully, it nuked items that I installed, but hope is diminished seeing as the Make it mine is still active somehow... Perhaps it does not need to be installed to retain the modifications...

    Hopefully they get Customize fixed, I loved that app :(

  • Judson
    Judson Posts: 8
    via Wordpress

    Can you still create ringtones from iTunes as mentioned earlier this week with the new firmware update?

  • Chris
    Chris Posts: 736
    via Wordpress

    if u update to 1.1.4 with a jailbroken and unlocked phone, will it brick ur iphone?

  • essmoe
    essmoe Posts: 7
    via Wordpress

    I have updated to 1.1.4 through itunes, and jailbroke it afterwards. Except for earlier mentioned apps. that doesn't worked yet on the 1.1.4 update, everything is fine.

    However, I still have problem with youtube. I haven't been able to use it since the 1.1.3 jailbreak. I have tried "thethreefiles" method, reseting my network settings, none worked.

    Btw, the custom ringtones throuhg itunes mentioned earlier this week still works on the new updated iphone!

  • aalanskrazyworld
    aalanskrazyworld Posts: 7
    via Wordpress

    i guess after we jailbreak firmware 1.1.3 using Zibri's
    method apps like youtube, weather, stocks, and or maps dont work... i realize that only one of the mentioned above dont work, like mickey mentioned above his youtube didnt work, i tried resetting everything but didnt work... so i took out the sim card and placed another one, i used a t-mobile one eventhough i have att as my provider, anyway after that youtube was fine in tmobile and in my att sim.... then on my friends phone the weather app wasnt working and he did the same thing and it also work!!! theres a tip!!! laterz!

  • Fingers
    Fingers Posts: 71
    via Wordpress

    I have managed to upgrade to 1.1.4, jailbreak AND UNLOCK my iphone, with no problems at all! I used ZIphone.

  • Louis
    Louis Posts: 180
    via Wordpress

    The latest feature in the 1.1.4 update is:

    If you click on settings, then General and About
    when you look at version it now reads 1.1.4

    Zibri;s method work but Summer board, dropcopy and a lot of the 1.1.3 apps won't install if they are designated to 1.1.3......labyrinth works

  • mike
    mike Posts: 489
    via Wordpress

    i jailbroke my 1.1.4 using iNdependence and then passed over installer 3.0.app to the phone. It all works and i was able to update the sources just fine, but everytime i try to install an app i get the "Main script execution failed!" error.

    anyone experiencing this?

  • Mario Genet
    Mario Genet Posts: 1
    via Wordpress

    I was able to use ziphone on firmware 1.1.4 but the only problem that i had is that when I try installing apps from the (installer) it won't let me becouse it seems like they are only made for firmware 1.1.3. Should we restore our phones or is the installer going to update so we can download the apps?

    Please let me know.


  • jstrang2
    jstrang2 Posts: 0
    via Wordpress

    sorry im kind of new to this i have installer on 1.1.3 but my iphone crashes to a blinking apple sign and the only way to fix is to connect to the charger and also can i restore while i have installer on my iphone?

  • Ken
    Ken Posts: 114
    via Wordpress

    I updated my iphone to 1.1.4 and jailbroke it as well but i cant install anything with the apps i keep getting an error message

  • Mickey3390
    Mickey3390 Posts: 9
    via Wordpress

    Can someone answer this Please? I have a valid ATT Account but none the less had to UNlock My IPhone to get it to work after I Jailbroke it on 1.1.3 using the installer method. What steps will I have to use to upgrade to the new 1.1.4 softwear and just jailbreak it and activate through ITunes? PLMK Thanks For your time and site both are great Regards Mickey

  • Michael Basquill Jr.
    via Wordpress


    This is an easy fix, that when applied, allows you to install all applications not yet produced for 1.1.4!

    I used this when 1.1.3 was first jailbroken, simply changing the SV to 1.1.1/1.1.2, thus fooling iTunes as well as Installer to think you are using 1.1.1/1.1.2 when in actual fact using 1.1.3, or 1.1.4 in this case.

    I did this manually, but Blaze has come up with an automated way to do it for the n00bs out there :-)

    Step-by-Step Intructions:






    It worked fine for me since the beginning of 1.1.3, and again on 1.1.4!

    Good luck!


  • Eeeee
    Eeeee Posts: 1
    via Wordpress

    for the main script error... ssh as root to your iphone:
    chmod ug+s /Applications/Installer.app/Installer

  • mike
    mike Posts: 489
    via Wordpress

    "for the main script error... ssh as root to your iphone:
    chmod ug+s /Applications/Installer.app/Installer"
    Posted by Eeeee

    thanks Eeeee, this fixed the main script error. I thought it might have to do with the permissions when i ran into it but kinda disregarded it. anyways thanks for the tip

    on that note, i decided to be nice and return the favor by putting a step-by step instruction set to get a 1.1.4 hacked iPhone to anyone who might be in need of it

    I'm using a Mac running Leopard:

    1) Download the latest build of iNdependence here http://code.google.com/p/independence/
    2) Download the Installer_3.0.app here http://hackthatphone.com/downloads/Installer.zip
    3) Unzip both downloaded packages. **Make sure to copy over the iNdependence application to your local disk instead of running it on the mounted disk i.e. drag the icon to your desktop from the mounted disk
    4) Click on the Jailbreak tab -> Perform Jailbreak
    *If it looks like its hanging, quit the program and try again
    5) After iNdependence works its magic you should now have your phone jailbroken
    6) Now to install the SSH, SCP and SFTP. Open iNdependence again and this time click the SSH tab -> Install SSH/SFTP/SCP. Its going to ask you to restart your iPhone about 3 times (once for each install)
    7) So lets summarize:
    -your iPhone is now jailbroken (i.e. you can write files to your iPhone)
    -you can write these files by using the SSH/SFTP/SCP protocols
    8) Now open iNdependence again and goto the Customize tab -> Applications. Its going to ask for your iPhone's IP Address and the root pwd which is 'alpine' (no quote's)
    9) After you log in, drag the Installer_3.0.app that you downloaded into iNdependence under Applications->System. Your iPhone will restart the springboard and you should see the Installer icon on your springboard.
    10) Open up the terminal on your mac and do the following commands:
    - type: ssh [email protected]'s IP i.e. ssh [email protected]
    - password is 'alpine'
    - type: chmod ug+s /Applications/Installer.app/Installer
    11) Restart your iPhone for re-assurance
    12) You now have a jailbroken iPhone
    13) Now proceed to install the Community Sources packages and the BSD package from the Installer.app on your iPhone and you're squared away

    hope this helps


  • mike
    mike Posts: 489
    via Wordpress

    for some reasons the links i posted aren't working so here are the links:

    -Step 1, iNdependence: http://code.google.com/p/independence/

    -Step 2: Installer_3.0.app:

    also, my little tutorial assumes you have 1.1.4 already loaded onto your iPhone


  • Ken
    Ken Posts: 114
    via Wordpress

    I tried the blaze sv patch on my jailbroken phone version 1.1.4 and it worked fine and i can now use all my third party apps ,


  • Peter Morris
    Peter Morris Posts: 1
    via Wordpress

    When it says "Download the Installer_3.0.app here" there is no link to the file.

    Can someone post the link please.

  • iPhoneHacks
    iPhoneHacks Posts: 2,315
    via Wordpress

    Hey mrocean,

    Mike added the links in the comment below his first comment, however I have now added the links in the first comment as well for benefit of other readers.

    Also find the links below for your reference:
    iNdependence - http://code.google.com/p/independence/
    Installer_3.0.app - http://hackthatphone.com/downloads/Installer.zip

    Thanks for highlighting it.

    iPhone Hacks

  • jonny
    jonny Posts: 12
    via Wordpress

    I downloaded that installer.zip file but when i try to open it it says "you cannot open the application "installer" 'cuz it is not supported on this sistem"

    -does anyone know what do i have to do?

  • El Mejor
    El Mejor Posts: 7
    via Wordpress

    How can I install shmod ug+s /applications/installer.app/installer on my iphone

  • Wes Priest
    Wes Priest Posts: 1
    via Wordpress

    I'm an idiot. mikey3390 put up a nice automated way to trick the installer into thinking the iPhone was running a different firmware.

    i CAN NOT for the life of me find Blaze's Repo in the installer following Mikey's first command:


    Any help with how to locate it would be most appreciated.


  • zlos.pl
    zlos.pl Posts: 1
    via Wordpress

    Regarding this:
    Installer_3.0.app - http://hackthatphone.com/downloads/Installer.zip

    1. Downloaded.
    2. Using Leopard it does not work :-( It says that is does not support my architecture... wtf?
    3. Stacked.

  • Albert Tan
    Albert Tan Posts: 1
    via Wordpress

    Does the Independence application works on Windows XP platform? Thanks!

  • ImOvaHereNow
    ImOvaHereNow Posts: 1
    via Wordpress

    I Upgraded to 1.1.4 ... ziphone-jailbreak'ed my iphone.. now my email doesn't work... i click the email button it opens to a white screen with a refresh button and a new mail button on the bottem.. then it closes..

    Any help??

  • AaronB
    AaronB Posts: 1
    via Wordpress

    Hi there,

    Perhaps someone could suggest some options to fix a broken iPhone after a failed install of 1.1.4

    I had an iPhone, unlocked for use with a GSM carrier overseas, jailbroken too, running 1.0.2

    I decided the time was ripe to upgrade to 1.1.4 and then unlock/jailbreak etc. However, the process didn't go smoothly, and now the phone part of the iPhone doesn't work.

    Can anyone suggest some options I can try to either completely "virginize" the iPhone back to factory state (OS, firmware, modem etc), or unlock the phone to work on my local phone carrier with the 1.1.4 in place?

  • du nguyen
    du nguyen Posts: 1
    via Wordpress

    I jailbroke my 1.1.4 iphone using ZiPhone (which is supposed to be used for 1.1.3 or less). Everything seemed find. But I got a couple of strange errors. One day, the phone just did not respond at all, even when I hit the power off button. I had to wait for the battery to go dead, recharge the phone. I had another problem which i believe was not a problem with the service provider. I could not make any call to any numbers. Others could not call my iphone as well. Whereas other cellphone owners who sat next to me could make calls.

    I recommend not using Ziphone to jailbreak your 1.1.4 iphone until ZiBri has a new release for iPhone 1.1.4

  • aj
    aj Posts: 82
    via Wordpress

    Sorry for the silly question, but how do i find out the iPhones IP address?
    ive done all the other steps successfully so far.

    and the password will be alpine?

    thanks in advance