Fix: GPS Not Working After Upgrading to iPhone Firmware 2.1

^_^ Posts: 4,429
via Wordpress in
imageFix: GPS Not Working After Upgrading to iPhone Firmware 2.1

The overall feedback from iPhone users about iPhone firmware 2.1 that was released by Apple last Friday has been very positive. It seems to have fixed most of the known problems with iPhone firmware 2.x.x such as dropped calls, slow iPhone syncs, iPhone apps crashing issues, 3G reception issues, Apple...

Read the full story here


  • Robert Lockey
    Robert Lockey Posts: 0
    via Wordpress

    Just read your post about 3G and GPS not working @ 2.1. I am on a 3g @ 2.1 and just tested GPS. My iPhone still works as designed.

  • L.A. King
    L.A. King Posts: 1
    via Wordpress

    That is interesting. I had all of the mentioned problems before the 2.1 update, and now every thing seems to be working perfectly.

  • Kevin
    Kevin Posts: 154
    via Wordpress

    well.. gps system works but now it's acting very wierd. For instance, it tells you to go past the target and take u-turn. I have no idea why it does that ;;; The map system got very unstable after the update.

  • karim
    karim Posts: 13
    via Wordpress

    I've got an pwned 1st gen iphone running 2.1.... but it still takes at least 2 hours to back up. This is ridiculous..... when will Apple get things right???

  • angel
    angel Posts: 81
    via Wordpress

    I have no problem with my GPS but i do have problem with updating any app i'm getting error message everytime i update.
    Does any one has any news about this?

  • iPhoneHacks
    iPhoneHacks Posts: 2,315
    via Wordpress

    Hey Angel,

    You might want to check this post to see if the workaround helps.


  • Lurch666
    Lurch666 Posts: 5
    via Wordpress

    @angel-I have always had this problem.It seems the old version of the app is not being deleted.If you manually delete the old version the update will then install.Also just found out my gps is not working after a 2.1 update *SOB*.Tried all the fixes I could find but no luck yet.

  • nicolasl46
    nicolasl46 Posts: 25
    via Wordpress

    I haven't tryed my GPS yet, but i noticed that after the 2.1 upgrade, my phone randombly switches from 3G to EDGE, and i'm not being able to surf or even text some times. Before it would take longer to switch bewtween services, but it hasn't got any better. It goes from having full 3G service to have Full EDGE service, if i have full 3G, why would it have to switch back to EDGE?

  • Tom
    Tom Posts: 314
    via Wordpress

    My GPS in Iphone 3G (2.1, jailbrokened) does not work at all - I tred do everything i found on the web (resetting, turning ON/OFF etc). Please help me, maybe there is some software fix for that.


  • nicolasl46
    nicolasl46 Posts: 25
    via Wordpress

    now people are having GPS problems regardles of the iphone being jailbroken or not?

  • terry
    terry Posts: 28
    via Wordpress

    My GPS not working on 3G unless i do the reset all settings. even then, the fix is temporary. if i travel in and out of Edge, it doesn't work again. this sux.

  • Benji
    Benji Posts: 18
    via Wordpress

    My GPS has never worked (I mean not even breifly, not ever!) since day one and I got the 3G on day of release. I tried everything and now with the 2.1 update it works outdoors and in!

    It seems that all the people that had GPS working are having problems and all that didnt seem to be fixed.

    Looks like Apple just cant get it right...

  • nicolasl46
    nicolasl46 Posts: 25
    via Wordpress

    update: my GPS does work, it was working before, it's been working since day one, and it's been working after every single update jailbroken or not. Everybody is getting different issues with the GPS, could it be that the update didn't install properly? Because the problems are software related, and we all get the update from. The same place!

    Posted from my iPhone.

  • verne brewster
    verne brewster Posts: 0
    via Wordpress


    gps on two iphones quit after the upgrade none of the fixes above worked on these phones

  • new to iphone
    new to iphone Posts: 2
    via Wordpress

    All methods have been tried, no luck to get GPS to work in China

  • Hisham Said
    Hisham Said Posts: 0
    via Wordpress

    My GPS was working fine before the update.
    I tried all the fixes:
    Reset all settings
    toggle on/off network settings
    toggle on/off set network locations
    soft reset the phone
    toggle off 3G
    downloaded another GPS application "track thing"
    nothing is working.
    what is really strange that it was working perfectly before 2.1?
    As if the firmware disabled the GPS...

  • Dm
    Dm Posts: 11
    via Wordpress

    Tried all fixes and GPS works sometimes on 3G but does not work when on Edge. Worked great before 2.1 update.

  • Art
    Art Posts: 13
    via Wordpress

    My problem with the GPS after the 2.1 update is now whenever a program asks me if it's ok to turn on "location services" and I click "ok" it doesn't turn it on. I have to manually go into settings and turn on location services. Prior to the update you didn't have to do this.

  • mfj197
    mfj197 Posts: 1
    via Wordpress

    User bcalisto on iphoneatlas has found a way to resolve the problem. It seems that the issue is with 2.1 that the maps app sometimes doesn't allow the GPS system enough time to obtain a lock before deciding that GPS isn't the way to go and disabling it. If you use another app (which doesn't behave in this fashion) to obtain a proper GPS lock first and then switch to maps, the lock is retained and it works fine. He mentions the free "TrackThing" app which I've just downloaded and it works very well - both the application itself and the fix!

    Incidentally immediately after the update my GPS worked properly every time whereas it was sporadic beforehand. But over the following weeks it's degraded to the stage that it hardly ever works at all. I'd tried all the resetting and turning things on and off that I could do. This fix works completely, as far as I can tell though!

    The complete story is here (bcalisto's solution is the last comment, on 20 September).

    I'm glad it's just a localised application thing with the mapps app, so if a turn-by-turn GPS system does come out (i.e. TomTom) it looks like it won't be afflicted with this problem.

  • RiCo
    RiCo Posts: 51
    via Wordpress

    I am on 2.2.1 and the maps only shows the blue crosshairs instead of the blue dot. I'm not sure if it happened after I upgraded firmware but I notice the problem happening after I started using the RunKeeper App.

    Everything was working great, then 3 runs later the app couldn't find my location, went to the map and noticed that the blue dot was nowhere to be found.

    Also, I have tried all of the recommended solutions and nothing seems to fix the problem.

  • iphone spy software
    via Wordpress
    My GPS was working well but now the same problem.